Interface Overview

NetVisualize Favorites Organizer is a new organizational tool that enables you to store and retrieve your important links to Internet sites, personal files, and more with ease and speed. NetVisualize Favorites Organizer provides hierarchical organization for your links, thumbnail images of your favorite web sites, and advanced search capabilities for finding specific links.



Main Window
The main NetVisualize window can be docked at the side of the user's desktop and set to be an application desktop toolbar (appbar). Options relating to these features are set in the Preferences dialog window.

Navigation

The main NetVisualize window is easily navigated with a mouse and supports many shortcut key combinations. In the Link Explorer Panel, a right-click with the mouse activates a popup menu from which you can select options to manipulate your links. Double-clicking with the left mouse button on a link opens the link.

Toolbar buttons are easy to use with their descriptive popup hints.

Modular Components

The Menu Bar, Toolbar, Search Bar, Thumbnail Panel, Notes Panel, and Details Panel are all modular and can be dragged by their handles (the vertical bars on the left side of the components) outside of the NetVisualize window. These components can be docked at the bottom of the NetVisualize window or remain free-floating elsewhere on the desktop. The positions of the modular components can be locked by checking the Lock Toolbars option or the Lock Dockable Panels option in the View menu.

View

The user can hide or show various components of the NetVisualize window via the View menu.

NetVisualize is minimized by left-clicking on the icon in the system tray or using the traditional minimize button on the title bar.

Tray Icon

NetVisualize optionally minimizes to the system tray. Right-clicking on the Tray Icon opens a popup menu containing the Links Popup Menu where all folders, links, and shortcuts in the open NetVisualize file are displayed and options to add, file, and open links are available. The Preferences dialog can also be accessed from the Tray Icon popup menu.

Popup thumbnail images are displayed as ToolTips when the mouse cursor is held over a link title in the Links Popup Menu. If a thumbnail image is not available, the URL of the link is displayed instead.

Thumbnail Images

The size of the thumbnail images that appear in the tray icon popup menu and thumbnail panel can be changed from the View tab of Preferences. The Preferences dialog is accessed from the Tools menu on the menu bar or the tray icon popup menu.